Notification of new incident, Delay in processing web requests.
Incident Report for uniFLOW Online
Resolved
Hello Everyone

We have not seen any reoccurrences of this issue and will close this long running status page. Closing off this status page means moving the incident status to resolved. At this point the root cause was not discovered. This is not the outcome we strive for however without further event metrics to investigate the current investigation is concluded.

What do we know?
During operation a web role would exhaust its resources and become unresponsive.

What did we do?
* We investigated the health of the web roles within Azure however there was no misconfiguration or obvious log errors.
* The Development and Operations team reviewed logs and analytics during the incidents with no clear root cause.
* During the investigation improvements to code handling were identified but could prove to be unrelated at this time.

Moving forward.
* The enhanced alerting and additional automated and manual monitoring will remain in place.
* The Operations team will review each week any reported issues that may indicate a link to the original issues.
* Any reoccurrence will be treated as a new case and investigated accordingly.

Thank you for your patience, apologies for any inconvenience caused.
Kind Regards
NT-ware Online Operations Team.
Posted Aug 15, 2023 - 01:11 UTC
Monitoring
Hello Everyone,

At this time, we have seen no more occurrences since last week which match the original issue seen in our telemetry. We will be moving the components back to 'Operational' however the status page will remain at 'Monitoring' for a little longer.

If you experience performance issues, please check this status for updates. New issues should be raised via your established support routes and investigated as new (possibly unrelated) cases. If we see a reoccurrence of last week's specific case in our monitoring and telemetry, a comment will be placed here immediately.

Apologies for any inconvenience.

Kind Regards,
Online Operations Team
Posted Aug 07, 2023 - 09:37 UTC
Investigating
Incident details:
We are investigating a non-persistent issue impacting the uniFLOW Online Singapore deployment.

Start Time:
Initially reported 17th of July, self-correct via auto scaling.
Issue reported as reoccurred on the 3rd of August.

Incident Scope: 
Singapore Deployment

Description:
This issue is under investigation but due to its non-persistent nature the root cause is still being investigated.

We are seeing a degradation on a single Web Role which services requests to uniFLOW Online. With many other web roles this means only a small number of requests are impacted and often re-requests are handled by working roles.

Mitigations:
Currently the Online Operations team have put in place additional monitoring and alerting. We are watching this service with the highest priority to reduce the impact to our customers.

Next Update:
The next update will be on Tuesday the 8th of August or as new information is available.
Posted Aug 04, 2023 - 08:47 UTC
This incident affected: SG Deployment (Identification, Printing, Scanning).