US Service Release Deployment Update to 2020.3.1
Scheduled for Nov 27, 06:00 - 08:00 UTC
Update
This is a reminder for this upcoming deployment update that will take place tomorrow.

Kind regards,
The uniFLOW Online team
Posted Nov 26, 2020 - 08:35 UTC
Scheduled
We’re excited to announce our next deployment update bringing you some bug fixes and performance improvements. Stay tuned for further updates via the usual channels!

Kind regards,
The uniFLOW Online team
Posted Nov 19, 2020 - 04:57 UTC
This scheduled maintenance affects: US Deployment (Identification, General Printing, Mobile Printing, Scanning, Reporting, Other Services).