Completed
The scheduled maintenance has been completed.
Posted Sep 18, 2024 - 19:29 UTC
Scheduled
Hello Everyone,
We’re scheduling this maintenance slot to bring you some bug fixes and performance improvements. The update will happen silently in the background with no expected disruption to service delivery.
Kind regards,
Online Operations Team
Posted Sep 16, 2024 - 19:34 UTC
This scheduled maintenance affected: EU Deployment (Identification, Printing, Email print, Scanning, Reporting, Other services), US Deployment (Identification, Printing, Email print, Scanning, Reporting, Other services), SG Deployment (Identification, Printing, Email print, Scanning, Reporting, Other services), AU Deployment (Identification, Printing, Email print, Scanning, Reporting, Other services), and UK Deployment (Identification, Printing, Email print, Scanning, Reporting, Other services).