Attachments not processed by Mobile Print
Incident Report for uniFLOW Online
Postmortem

User Impact

Any user on the US deployment will have noticed that mobile print jobs sent by email were not arriving in the secure print queue for release.

Scope of Impact

  • This was limited to only Mobile print jobs submission, using the web upload option was not affected.
  • Was affecting both named user and guest mobile print job.
  • Importantly no jobs were lost as and our telemetry is now showing jobs sent earlier today are being processed and delivered for release.

Incident Start Date and Time

Oct 05, 2020 - 11:30 UTC

Incident End Date and Time

Oct 06, 2020 - 06:00 UTC

Root Cause

NT-ware utilities a robust and heavily secured email systems to protect our customers data in transit. To this end we are always improving security and techniques to combat against SPAM and internet based attacks. In this case a security rule was triggered and blocked emailed delivery to uniFLOW Online that was in fact legitimate. The cause down to the volume and delivery pattern being misinterpreted as an attack.

Lessons Learnt

At the time of resolution to this incident the block has been removed and the security rule updated to ensure it is not triggered this way in the future. The impact to our user based is regrettable but NT-ware will always put security and privacy first. This incident has helped us better tune our systems and service delivery.

Posted Oct 06, 2020 - 06:29 UTC

Resolved
This incident has been resolved.
Posted Oct 06, 2020 - 06:08 UTC
Investigating
Identified: 11:30 UTC on 5-10-2020

Incident Scope: US Deployment Only

Description:
The US deployment is currently experiencing issues processing mobile print jobs with attachments. If an attachment is uploaded via the web page from within your tenant however this works fine.

We have begun investigating this issue with our operations team.

Next Update:
The next update will be at 6am UTC on the 6-10-2020 or sooner as details are available.
Posted Oct 06, 2020 - 00:32 UTC
This incident affected: US Deployment (Mobile Printing).