Some users cannot sign into uniFLOW Online using their Microsoft 365 credentials
Incident Report for uniFLOW Online
Postmortem

Dear Customers,

As experienced on March 15th logging into uniFLOW Online with your Microsoft credentials may have failed. This was down to a global outage experienced by Microsoft impacting their ability to service identity provider end points among other services. This was not affecting our other supported identity service providers (Okta, PingIdentity, etc). For organizations that have access to multiple identity providers this could be an option for the future to ensure you retain access in the event one service goes offline.

Please find below the Post Mortem/Root Cause published by Microsoft for the March 15th outage.

RCA - Authentication errors across multiple Microsoft services (Tracking ID LN01-P8Z)

Azure status history | Microsoft Azure

Posted Mar 18, 2021 - 21:40 UTC

Resolved
Hello All
NT-ware will be closing off this incident at this time. Microsoft systems are reporting a reduction in telemetry errors and we are not seeing login failures from our global test deployments or dependent services. We will continue to monitor the Microsoft status pages and link to their Post Mortem when available.

Last update from Microsoft: (https://twitter.com/MSFT365Status)
The update has finished deployment to all impacted regions. Microsoft 365 services are showing decreasing error rates in telemetry. We’ll continue to monitor service health status. Additional information can be found at http://status.office.com and https://status.azure.com/en-us/status

Note: We cannot set a Post Mortem response time as this is in the hands of a 3rd party.
Posted Mar 15, 2021 - 23:08 UTC
Update
CURRENT STATUS: Engineering teams have rolled out a fix to all affected regions. Internal telemetry and customer reports suggests that the error rate for dependent services is rapidly decreasing. Microsoft services are starting to see signs of recovery. Some services and offerings may have varying times of recovery following the underlying fix. The next update will be provided in 60 minutes or as events warrant.
Posted Mar 15, 2021 - 22:05 UTC
Update
Microsoft Update:
SUMMARY OF IMPACT: Starting at approximately 19:15 UTC on 15 Mar 2021, a subset of customers may experience issues authenticating into Microsoft services, including Microsoft Teams, Office and/or Dynamics, Xbox Live, and the Azure Portal. Other Azure services/offerings that rely on authentication infrastructure downstream may see further impact.

CURRENT STATUS: Engineering teams have rolled out a fix to all affected regions. Internal telemetry and customer reports suggests that the error rate for dependent services is rapidly decreasing. Microsoft services are starting to see signs of recovery. Some services and offerings may have varying times of recovery following the underlying fix.
Posted Mar 15, 2021 - 22:01 UTC
Monitoring
Engineering teams are currently rolling out mitigation worldwide. Customers should begin seeing recovery at this time, with full mitigation expected within 60 minutes.
Posted Mar 15, 2021 - 21:16 UTC
Investigating
Incident details:
Identified: March 15th, 2021 - 19:15 UTC

Incident Scope:
Microsoft has reported authentication errors across multiple Microsoft services.
uniFLOW Online customers using other identity providers (e.g. Google or Okta) are not affected by this.

Description:
Starting at approximately 19:15 UTC on 15 Mar 2021, a subset of customers may experience issues authenticating into Microsoft services.
Microsoft's Engineering teams have been engaged and are currently investigating.

Next Update:
The next update will be provided in 60 minutes or as events warrant.

Kind regards,
The uniFLOW Online team
Posted Mar 15, 2021 - 21:04 UTC
This incident affected: AU Deployment (Identification), JP Deployment (Identification), UK Deployment (Identification), EU Deployment (Identification), SG Deployment (Identification), US Deployment (Identification), and CN Deployment (Identification).