Continuation of incident: Microsoft Universal Print jobs failing: All deployments
Incident Report for uniFLOW Online
Postmortem

User Impact 

Tenants making use of the Universal Print by Microsoft Extension would have had their Universal Print by Microsoft jobs not processed. Print jobs submitted to Universal Print by Microsoft print queues would remain in a Pending state in the print queue and not be picked up by uniFLOW Online for further processing. 

Scope of Impact 

  • Universal Print by Microsoft extension customers in all regions. 
  • As per the root cause only expired or expiring tenants were impacted. 

Incident Start Date and Time 

Apr 7, 2024 - 10:30 UTC 

Incident End Date and Time 

Apr 9, 2024 - 15:55 UTC 

Root Cause 

When a new print job enters the Universal Print by Microsoft print queue a notification is sent to uniFLOW Online to retrieve the print job and process it further within uniFLOW Online. These notifications are received through a notification subscription that uniFLOW Online creates when Universal Print by Microsoft is configured. This subscription is valid for 70 hours and is periodically renewed by uniFLOW Online on a per-tenant basis to continue receiving that tenant’s print job notifications. This subscription renewal process makes use of an NT-ware managed application secret. 

On 6 April 2024 the application secret expired. This was caused by a previous deployment update to the Universal Print by Microsoft components that set a shorter (default) expiry then was previously being monitored for. 

 This meant that notification subscriptions were no longer being successfully renewed for tenants. Tenants would however have continued to function normally without any impact until the existing notification subscription expires. Once a tenant’s notification subscription expires it would no longer have been possible for uniFLOW Online to be notified of new print jobs from Universal Print by Microsoft and the print jobs would remain in a Pending state in the Universal Print by Microsoft queue. 

On 8 April 2024 the application secret was renewed and applied to all uniFLOW Online deployments to allow the notification subscriptions to be renewed as before. This did require a gradual rollout which started at 12:45 UTC and finished globally at 17:00 UTC. From 12:45 UTC tenant’s notification subscription renewals may have succeeded, and normal functionality would continue for these tenants. 

There were, however, tenants where the notification subscription expired could not be renewed. For these tenants a new notification subscription had to be created. On 9 April 2024 at 15:30 UTC a fix was rolled out targeting these tenants to create a new notification subscription. At 15:55 UTC these tenants had new notification subscriptions created which restored Universal Print by Microsoft functionality for these tenants. 

Next Steps 

We apologize for the impact to affected customers. We are continuously taking steps to improve the uniFLOW Online Platform and our processes to help ensure such incidents do not occur in the future. In this case, this includes (but is not limited to): 

  • We have identified the root cause of the secret not being renewed and have already addressed this to ensure that this does not occur in future.
Posted Apr 15, 2024 - 09:35 UTC

Resolved
Hello Everyone,

Update: Incident Resolved. The fix has now been successfully rolled out and all impacted tenants now have their Universal Print by Microsoft functionality restored.

Date/Time: April 9th, 3:55 pm UTC

We will review the findings and collected information from this incident to further improve our online services. There will be a postmortem published for Major (max 20 business days) incidents once a thorough investigation has been completed.

We are sorry for the inconvenience this has caused.

Kind Regards
Online Operations Team
Posted Apr 09, 2024 - 16:03 UTC
Monitoring
Update:
We have begun rolling out a fix for this issue and impacted tenants will now gradually start recovering their Universal Print by Microsoft functionality.
We are monitoring the recovery of tenants and will provide an update once all impacted tenants are resolved.

Next Update:
The next update will be in 2 hours or once the issue is resolved.
Posted Apr 09, 2024 - 15:39 UTC
Update
Update:
We are continuing to work on a fix for the affected tenants.

Next Update:
The next update will be in 2 hours.
Posted Apr 09, 2024 - 14:06 UTC
Identified
Update:
The NT-ware Operations team have identified a potential cause for these tenants not retrieving print jobs from Universal Print by Microsoft.
We are continuing to work on a potential fix for the affected tenants.

Next Update:
The next update will be in 2 hours.
Posted Apr 09, 2024 - 11:57 UTC
Investigating
Incident details:

Investigating:
We are investigation reports of some tenants' Universal Print by Microsoft jobs not being processed. This is a continuation of the incident reported in the EU deployment yesterday (8 April 2024).

Start Time:
11:50 UTC 8/4/2024

Incident Scope:
All Deployments.

Description:
Following the restoration of services yesterday (8 April 2024) there are still some tenants experiencing problems with Universal Print by Microsoft whereby print jobs are failing to be picked up by uniFLOW Online for further processing. Note that this is not impacting all tenants.
The NT-ware Operations team have identified a potential cause for these tenants not retrieving print jobs from Universal Print by Microsoft and are investigating it further.

Next Update:
The next update will be in 2 hours.
Posted Apr 09, 2024 - 10:01 UTC
This incident affected: EU Deployment (Identification, Printing, Email print, Scanning, Reporting, Other services), US Deployment (Identification, Printing, Email print, Scanning, Reporting, Other services), SG Deployment (Identification, Printing, Email print, Scanning, Reporting, Other services), AU Deployment (Identification, Printing, Email print, Scanning, Reporting, Other services), JP Deployment (Identification, Printing, Email print, Scanning, Reporting, Other services), and UK Deployment (Identification, Printing, Email print, Scanning, Reporting, Other services).